Benutzer-Werkzeuge

Webseiten-Werkzeuge


psd2

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
psd2 [d.m.Y H:i]
willuhn [Ab welcher Version ist Hibiscus PSD2-fähig]
psd2 [d.m.Y H:i] (aktuell)
willuhn [Auswirkungen auf den Hibiscus Payment-Server]
Zeile 3: Zeile 3:
 \\ \\
  
-| ** Vorab** \\ \\ **Bevor du all das hier durchliest, mach einfach ein [[support:​update|Update auf Hibiscus 2.8.16]] ("​Datei->​Einstellungen->​Plugins ->​Updates"​). Wenn du das erledigt hast, ist das Thema PSD2 für dich vermutlich schon erledigt** ;-) |+| ** Vorab** \\ \\ **Bevor du all das hier durchliest, mach einfach ein [[support:​update|Update auf Hibiscus 2.8.17]] ("​Datei->​Einstellungen->​Plugins ->​Updates"​) ​und lösche die BPD, wie [[support:​faq#​bpd_aktualisieren|hier beschrieben]]. Wenn du das erledigt hast, ist das Thema PSD2 für dich vermutlich schon erledigt** ;-) |
  
 \\ \\
Zeile 64: Zeile 64:
 PIN/TAN ist das mit Abstand gebräuchlichste Verfahren. Wenn du nicht genau weisst, welches Verfahren du verwendest, dann ist es mit ziemlicher Sicherheit PIN/TAN. Hierbei spielt es keine Rolle, ob du einen TAN-Generator,​ eine Smartphone-App oder SMS verwendest. Es sind alles PIN/​TAN-Varianten. PIN/TAN ist das mit Abstand gebräuchlichste Verfahren. Wenn du nicht genau weisst, welches Verfahren du verwendest, dann ist es mit ziemlicher Sicherheit PIN/TAN. Hierbei spielt es keine Rolle, ob du einen TAN-Generator,​ eine Smartphone-App oder SMS verwendest. Es sind alles PIN/​TAN-Varianten.
  
-Du musst **zwingend auf Hibiscus 2.8.16** oder neuer (alternativ ein Nightly-Build ab 30.08.2019) aktualisieren. Dein Bank-Zugang wird sonst spätestens ab 14.09.2019 nicht mehr funktionieren. [[support:​update|Hier]] findest du Informationen,​ wie du Hibiscus aktualisierst. Falls dir das Update nicht angeboten wird, ist wahrscheinlich deine Jameica-Version zu alt. Siehe hierzu die [[#​ich_finde_keine_aktuellere_hibiscus-version|häufigen Fragen]].+Du musst **zwingend auf Hibiscus 2.8.17** oder neuer (alternativ ein Nightly-Build ab 30.08.2019) aktualisieren. Dein Bank-Zugang wird sonst spätestens ab 14.09.2019 nicht mehr funktionieren. [[support:​update|Hier]] findest du Informationen,​ wie du Hibiscus aktualisierst. Falls dir das Update nicht angeboten wird, ist wahrscheinlich deine Jameica-Version zu alt. Siehe hierzu die [[#​ich_finde_keine_aktuellere_hibiscus-version|häufigen Fragen]].
  
 === Mehr TANs === === Mehr TANs ===
Zeile 119: Zeile 119:
  
 Falls auf dem Hibiscus Payment-Server jedoch ein PIN/​TAN-Zugang verwendet wird, um die Umsatzbuchungen automatisiert abzurufen, dann kann es in der Tat sein, dass der Zugang ab 14.09.2019 nicht mehr funktioniert. Nämlich genau dann, wenn die Bank bereits für den Umsatzabruf eine TAN haben möchte (siehe [[#​mehr_tans|weiter oben]]). Da der Hibiscus Payment-Server prinzipbedingt aufgrund der Programmausführung im Hintergrund keine Benutzerinteraktion zulässt, ist demzufolge auch keine TAN-Eingabe möglich. Der Server wird die Synchronisierung in dem Fall mit einer Fehlermeldung stoppen. Falls auf dem Hibiscus Payment-Server jedoch ein PIN/​TAN-Zugang verwendet wird, um die Umsatzbuchungen automatisiert abzurufen, dann kann es in der Tat sein, dass der Zugang ab 14.09.2019 nicht mehr funktioniert. Nämlich genau dann, wenn die Bank bereits für den Umsatzabruf eine TAN haben möchte (siehe [[#​mehr_tans|weiter oben]]). Da der Hibiscus Payment-Server prinzipbedingt aufgrund der Programmausführung im Hintergrund keine Benutzerinteraktion zulässt, ist demzufolge auch keine TAN-Eingabe möglich. Der Server wird die Synchronisierung in dem Fall mit einer Fehlermeldung stoppen.
-Hier bleibt nur zu hoffen, dass die Bank nur dann eine TAN haben möchte, wenn die Umsätze älter als 90 Tage sind. Gegebenenfalls kann es auch nötig sein, parallel zum Hibiscus-Server auf einem anderen Computer die Desktop-Version von Hibiscus zu installieren,​ und dann von dort aus mit der gleichen Benutzerkennung das Konto von Zeit zu Zeit zu synchronisieren und die eventuell nötigen TANs dort einzugeben. Dies würde bewirken, dass das seitens der Bank geführte 90-Zeitfenster für diese Benutzerkennung zurückgesetzt würde und der Hibiscus-Server nicht mit einer TAN-Abfrage konfrontiert wird.+Hier bleibt nur zu hoffen, dass die Bank nur dann eine TAN haben möchte, wenn die Umsätze älter als 90 Tage sind. Gegebenenfalls kann es auch nötig sein, parallel zum Hibiscus-Server auf einem anderen Computer die Desktop-Version von Hibiscus zu installieren,​ und dann von dort aus mit der gleichen Benutzerkennung das Konto von Zeit zu Zeit zu synchronisieren und die eventuell nötigen TANs dort einzugeben. Dies würde bewirken, dass das seitens der Bank geführte 90-Zeitfenster für diese Benutzerkennung zurückgesetzt würde und der Hibiscus-Server nicht mit einer TAN-Abfrage konfrontiert wird. Achte ausserdem darauf, auf dem Hibiscus-Server pro Konto maximal 4 mal täglich die Umsätze abzurufen. Es gibt eine Regelung, nach der die Bank von der TAN-Ausnahme nur höchstens 4 mal täglich Gebrauch machen kann.
  
 Das sind jedoch bisher nur Vermutungen. Wie sich die System tatsächlich verhalten werden, wird sich leider erst ab dem 14.09.2019 zeigen. Das sind jedoch bisher nur Vermutungen. Wie sich die System tatsächlich verhalten werden, wird sich leider erst ab dem 14.09.2019 zeigen.
Zeile 126: Zeile 126:
  
   - Wenn du **Schlüsseldatei oder DDV-Chipkarte** verwendest, **sollte** es zumindest rein technisch auch **nach dem 14.09.2019 noch funktionieren** - es sei denn, deine Bank hat es eingestellt,​ ohne dir das mitzuteilen oder du hast die Mitteilung übersehen.   - Wenn du **Schlüsseldatei oder DDV-Chipkarte** verwendest, **sollte** es zumindest rein technisch auch **nach dem 14.09.2019 noch funktionieren** - es sei denn, deine Bank hat es eingestellt,​ ohne dir das mitzuteilen oder du hast die Mitteilung übersehen.
-  - Wenn du **PIN/TAN** verwendest, musst du **zwingend auf Version 2.8.16** oder neuer (alternativ ein Nightly-Build ab 30.08.2019) aktualisieren. Auch wenn der Hibiscus-Server keine TAN-Anfrage beantworten kann, so muss er dennoch ab 14.09.2019 bei der Datenübertragung zur Bank mitteilen, dass er es prinzipiell könnte. Ob dann tatsächlich eine TAN nötig ist, entscheidet die Bank.+  - Wenn du **PIN/TAN** verwendest, musst du **zwingend auf Version 2.8.17** oder neuer (alternativ ein Nightly-Build ab 30.08.2019) aktualisieren. Auch wenn der Hibiscus-Server keine TAN-Anfrage beantworten kann, so muss er dennoch ab 14.09.2019 bei der Datenübertragung zur Bank mitteilen, dass er es prinzipiell könnte. Ob dann tatsächlich eine TAN nötig ist, entscheidet die Bank. Stelle das Synchronisationsintervall so ein, dass höchstens 4 mal täglich die Umsätze abgerufen werden.
 ===== Häufige Fragen ===== ===== Häufige Fragen =====
 ---- ----
Zeile 143: Zeile 143:
  
 Ab Version 2.8.14 bzw. einem Nightly-Build ab dem 30.08.2019. Ab Version 2.8.14 bzw. einem Nightly-Build ab dem 30.08.2019.
-Mit den Folgeversionen (aktuell 2.8.16) wurden weitere PSD2-relevante Fehler behoben. Weitere Bugfix-Releases folgen u.U. noch.+Mit den Folgeversionen (aktuell 2.8.17) wurden weitere PSD2-relevante Fehler behoben. Weitere Bugfix-Releases folgen u.U. noch.
  
 ==== Ich finde keine aktuellere Hibiscus-Version ==== ==== Ich finde keine aktuellere Hibiscus-Version ====
  
-Hibiscus 2.8.16 setzt mindestens Jameica 2.8 voraus. Wenn du das Online-Update auf die aktuelle Hibiscus-Version 2.8.16 nicht angeboten bekommst, ist deine Jameica-Version zu alt. Vermutlich verwendest du noch Jameica 2.6.+Hibiscus 2.8.17 setzt mindestens Jameica 2.8 voraus. Wenn du das Online-Update auf die aktuelle Hibiscus-Version 2.8.17 nicht angeboten bekommst, ist deine Jameica-Version zu alt. Vermutlich verwendest du noch Jameica 2.6.
  
 Beachte, dass Jameica 2.8 mindestens Java 8 oder höher benötigt. Falls du also noch Java 6 oder Java 7 installiert hast, aktualisiere dieses ebenfalls. Unabhängig davon gelten Java 6 und 7 ohnehin als veraltet. Beachte, dass Jameica 2.8 mindestens Java 8 oder höher benötigt. Falls du also noch Java 6 oder Java 7 installiert hast, aktualisiere dieses ebenfalls. Unabhängig davon gelten Java 6 und 7 ohnehin als veraltet.
Zeile 157: Zeile 157:
   * Eventuell sind die BPD (Bank-Parameter-Daten) noch nicht aktuell. In dieser [[support:​faq#​bpd_aktualisieren|Anleitung]] findest du Informationen zum Aktualisieren der Bank-Parameter. Unter Umständen kann es auch nötig sein, den Bankzugang zu löschen und neu anzulegen. Die Konten und Umsätze gehen hierbei nicht verloren.   * Eventuell sind die BPD (Bank-Parameter-Daten) noch nicht aktuell. In dieser [[support:​faq#​bpd_aktualisieren|Anleitung]] findest du Informationen zum Aktualisieren der Bank-Parameter. Unter Umständen kann es auch nötig sein, den Bankzugang zu löschen und neu anzulegen. Die Konten und Umsätze gehen hierbei nicht verloren.
   * Stelle sicher, dass du wirklich aktualisiert hast. Klicke im Menü auf "​Hibiscus->​Über"​.   * Stelle sicher, dass du wirklich aktualisiert hast. Klicke im Menü auf "​Hibiscus->​Über"​.
-    * Dort sollte bei "​Software-Version"​ "2.8.16" oder höher stehen (alternativ "​2.9.0-nightly",​ vorausgesetzt das Datum bei "​Build"​ ist mindestens "​20190830"​.+    * Dort sollte bei "​Software-Version"​ "2.8.17" oder höher stehen (alternativ "​2.9.0-nightly",​ vorausgesetzt das Datum bei "​Build"​ ist mindestens "​20190830"​.
     * Bei "​HBCI4Java-Version"​ sollte mindestens 3.1.4 stehen.     * Bei "​HBCI4Java-Version"​ sollte mindestens 3.1.4 stehen.
     * Werden dort ältere Versionen angezeigt, aktualisiere Hibiscus per "​Datei->​Einstellungen->​Plugins"​. Kopiere eine neuere Version von Hibiscus nicht über eine alte Version drüber - hierbei können Fragmente der Vorversion erhalten bleiben. Siehe [[support:​update|Update-Anleitung]]     * Werden dort ältere Versionen angezeigt, aktualisiere Hibiscus per "​Datei->​Einstellungen->​Plugins"​. Kopiere eine neuere Version von Hibiscus nicht über eine alte Version drüber - hierbei können Fragmente der Vorversion erhalten bleiben. Siehe [[support:​update|Update-Anleitung]]
Zeile 164: Zeile 164:
 ==== Meine Bank unterstützt PSD2 noch gar nicht ==== ==== Meine Bank unterstützt PSD2 noch gar nicht ====
  
-Hibiscus 2.8.16 verwendet für die Kommunikation mit der Bank ausschließlich das neue PSD2-Verfahren mit den zusätzlichen TAN-Abfragen. Wenn deine Bank noch nicht auf PSD2 umgestellt hat, kann es mit der neuen Hibiscus-Version zu Fehlern kommen. Die Fehlermeldung der Bank lautet typischerweise "​9180:​Wird nicht bzw. nicht mehr unterstützt"​. Das betrifft z.Bsp. derzeit die Deutsche Bank (siehe [[https://​homebanking-hilfe.de/​forum/​topic.php?​t=23127|Forum]]).+Hibiscus 2.8.17 verwendet für die Kommunikation mit der Bank ausschließlich das neue PSD2-Verfahren mit den zusätzlichen TAN-Abfragen. Wenn deine Bank noch nicht auf PSD2 umgestellt hat, kann es mit der neuen Hibiscus-Version zu Fehlern kommen. Die Fehlermeldung der Bank lautet typischerweise "​9180:​Wird nicht bzw. nicht mehr unterstützt"​. Das betrifft z.Bsp. derzeit die Deutsche Bank (siehe [[https://​homebanking-hilfe.de/​forum/​topic.php?​t=23127|Forum]]).
  
 In dem Fall kannst du übergangsweise nochmal ein Downgrade zurück auf Hibiscus 2.8.13 durchführen. Den Download sowie eine Anleitung zur Installation findest du [[https://​www.willuhn.de/​products/​hibiscus/​download_ext.php|hier]]. In dem Fall kannst du übergangsweise nochmal ein Downgrade zurück auf Hibiscus 2.8.13 durchführen. Den Download sowie eine Anleitung zur Installation findest du [[https://​www.willuhn.de/​products/​hibiscus/​download_ext.php|hier]].
 +==== Comdirect funktioniert nicht ====
 +
 +Stelle sicher, dass du Hibiscus 2.8.17 verwendest. Bis Version 2.8.16 kam es hier noch zu einem Fehler. Aktualisiere auf die neue Version per "​Datei->​Einstellungen->​Plugins->​Updates"​.
 +
 ==== Die ING schrieb mir, mein Banking-Programm soll die PSD2-API verwenden ==== ==== Die ING schrieb mir, mein Banking-Programm soll die PSD2-API verwenden ====
  


Impressum | Datenschutz
psd2.1568298123.txt.gz · Zuletzt geändert: d.m.Y H:i von willuhn